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AceProject offers a wide range of access rights at both the user and project level. Access rights are very flexible. They allow administra-
tors and project managers to grant the right privileges to the right users.

The User Access Rights
The user access rights are used to grant privileges with regards to actions that can be performed in the account. Only administrators can grant these access rights, under “Admin -> Users”. 

•	For better understanding, the graph below illustrates the user access rights. The main access right is the “Access Level”. The additional user access rights are: Status, Time  
		  Entry Mode, Email Notifications, User Directory and Show/Hide Help.

Access Levels
		  The Access Levels are used to define whether a resource is an administrator or a normal user.

 

Status
		  The Status access right is used to set whether a user can access AceProject or not and whether you wish to have the user appear in lists for new assignements or not.

•	The “Active - Access Allowed” option is set as default. It allows the user to access the account.

•	The “Active - Access Denied” option prevents a user from loging in. However, users under this status will be available for new assignments.

•	The “Inactive - Access Denied” option allows you to disable a user without deleting it and losing important historical data. Users under this status will not be available  
				    for new assignments. However, these users will not be unassigned from projects and tasks when their status is changed from an Active status to the Inactive status.  
				    Wherever they are already assigned, they will remain visible in the lists. Finally, AceProject does not send out email notifications to inactive users.

Email Notifications
		  The Email Notifications access right enables you to decide whether the user can edit his/her email notification preferences under “My Office -> My Preferences”.

Time Entry Mode
		  The Time Entry Mode access right is used to define the method a user will use to fill timesheets. It can be manually by using the timesheet module, automatically by using  
		  the IN/OUT time clock module or both options combined. The following options are available:

•	“Timesheet + IN/OUT” offers the flexibility to fill timesheets either manually or automatically, as mentioned earlier.

•	“Timesheet Only” forces a user to enter his/her time manually through the timesheet module, which is located under “My Office -> My Time Sheets”. In that case,  
				    the IN/OUT module is not available for time entry.

•	“IN/OUT Only” forces a user to use the IN/OUT time clock module for time entry. The time clock can be started and stopped within a task, or under “My Office ->  
				    My Time Sheets -> My IN/OUT”. This option ensures efficient monitoring of users, since they cannot edit their time once entered.

•	“Time Entry Disabled” prevents a user from entering time in AceProject, as both time tracking modules are not available.

		

		

ACCESS RIGHTS

Administrator

An administrator has full control over the account.

An administrator can see the “Admin” tab at the top of the application.

An administrator can view either their assigned projects or all projects under the 
“Portfolio” tab at the top of the application.

Exclusive actions for administrators include:

•	 Manage all users, import data, delete projects and delete user items.

•	 Manage the account information, user groups, time types, project types, project  
      priorities, project statuses and clients.

•	 Open and edit every project and every task, even if they are not assigned to it.

Generally, to ensure optimal security, the number of administrators should be as 
minimal as possible.

Normal

A normal user’s access rights may vary from project to project. Access rights are 
granted by a project manager or an administrator when the user is assigned to a 
project.

Once the user is assigned to the project, he/she will be allowed to perform actions 
in accordance with the access rights he/she has been granted.

Projects that are not assigned to a normal user will not be viewable.

The “Can add a project” access right enables the user to create a blank project or 
copy any project template he/she is assigned to.

The “Show the Project Portfolio Tab” access right is like an enhanced “project” tab. 
When this mode is enabled, the “Portfolio” tab is available at the top of the applica-
tion. It provides features like Gantt charts, time reports or task reports for all the 
user’s assigned projects. This access right does not give access to the account or 
user configuration however.

•	 This access right grants the “Can Open This Project” access right automatically. In  
      other words, even if a user is assigned to a project but cannot open it, the “Show  
      the Project Portfolio Tab” will give him/her the right to open it. However, the  
      behaviour of the “Project Manager”, the “Time Approval” and the “Edit Task Level”  
      access rights will remain the same.

The “Can see financial data” access right allows the user to view the project’s “Bud-
get” group, as well as the Total Task Expenses, Total Project Expenses and Total 
Expenses values on all assigned projects.
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			   Time can be entered based on these conditions:

1.	 Time can be added to incomplete projects only.

2.	 Time can be added to both incomplete and completed tasks.

			   	 	 •	 If you have the “Can Open this Project” access right in a project, you can add time to the project itself and any task in the project.

	 	 	 	 	 •	 If you don’t have the “Can Open this Project” access right in a project, you can only add time to tasks you are assigned to or reviewer on.

Expense Entry Mode
		  The Expense Entry Mode access right is used to define whether or not a user will be allowed to add expenses. Additionally, this is where you will indicate if the user has the  
		  right to approve his own expenses.

			   Expenses can be entered based on these conditions:

1.	 Expenses can be added to incomplete projects only.

2.	 Expenses can be added to both incomplete and completed tasks.
	 	 •	 If you have the “Can Open this Project” access right in a project, you can add expenses to the project itself and to any task in the project.

	 	 •	 If you don’t have the “Can Open this Project” access right in a project, you can only add expenses to the project itself or to tasks you are assigned to or reviewer on.

•	For Normal users, the “Can approve own expenses” right only applies to projects the user is assigned to and on which he/she has the «Expense Approval» right.

User Directory
		  The User Directory access right is used to set permissions in regard to the resources displayed in a user’s “User Directory” (located under “My Office -> My User Directory”).  
		  This feature actually displays other user’s contact information, such as phone numbers and email addresses. The following options are available:

•	“Display All Users” lists all existing users in your account.

•	“Display Only Administrators” lists administrators only. In that case, normal users are not listed.

•	“Users Assigned on the Same Projects” lists users assigned on the same projects. In that case, users assigned on other projects are not listed.

•	“Users in the Same Group” lists users associated with the same user group. For example, an architect would only see other architects. In that case, users  
				    associated with other user groups are not listed.

•	“Disabled” prevents a user from viewing the user directory in the “My Office” section. This option ensures confidentiality as a user cannot find the other user’s  
				    contact information.

Show/Hide Help
		  The Show/Hide Help access right is used to decide whether the contextual help link and the “Help” tab are available to a user. 

•	The “Hide Help Tab” checkbox enables you to prevent the user from seeing the “Help” tab.

•	The “Hide Contextual Help Link” checkbox enables you to prevent the user from seeing the “Contextual Help” links, at the upper right of all pages.

The Project Access Rights
The project access rights are used to grant privileges at the project level. Both administrators and project managers can grant these access rights under “Open Project Tab -> 
Configuration -> Assigned Users”. The project access rights are the following: Project Manager, Time Approval, Project Access and the Edit Task Levels.

•	The graph below shows a few project assignment scenarios. 

Full control  
over the project

•	 Project Manager : Yes*

•	 Time Approval : Yes

•	 Expense Approval : Yes

•	 Edit Task Level : D2 - Level 2, Full    
      Control Task Editing 

•	 Can Open Project : Yes

Once the “Project Manager” access 
right is granted, the “Time Approval”, 
the “Can Open Project” access rights 
and the highest “Edit Task Level” are 
granted automatically.

Client Access 
 for Task Review Only

•	 Project Manager : No

•	 Time Approval : No

•	 Expense Approval : No

•	 Edit Task Level : A1 - Read Only  
      Task Editing

•	 Can Open Project : No*

Thus, the client can only view his/her 
assigned tasks under « My Office -> 
My Tasks ». In this example, the client  
cannot view any project-related task  
report, Gantt chart, calendar or statistics.

Time Sheet Approval and  
Time Report Access Only

•	 Project Manager : No

•	 Time Approval : Yes

•	 Expense Approval : No

•	 Edit Task Level : A1 - Read Only  
      Task Editing

•	 Can Open Project : Yes

In this example, the user cannot edit  
his/her assigned tasks, but can open 
the project to approve/reject time 
sheets, generate time reports and 
view other data for the actual project.

Partial Task Editing But No  
Access to Time Data

•	 Project Manager : No

•	 Time Approval : No

•	 Expense Approval : 

•	 Edit Task Level : C2 - Level 2,  
      Partial Task Editing

•	 Can Open Project : Yes

This is an example of common project 
access rights a user may be granted.  
He/she can open the project and edit 
his/her assigned tasks partially, without  
having access to other users’ time 
sheets and time reports in the project.
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The Edit Task Levels
		  The edit task levels are used to define the actions a user can perform on tasks he is associated with. These levels are very flexible. They are actually separated in four  
		  modes: Read Only, Limited, Partial, and Full Control.

: Yes 
: No

: Task Creator 
: Assigned / Reviewer 
: Not Creator / Not Assigned / Not Reviewer

A1 : Read Only Task Editing	
B1 : Level 1, Limited Task Editing	
B2 : Level 2, Limited Task Editing	
C1 : Level 1, Partial Task Editing	
C2 : Level 2, Partial Task Editing	
D1 : Level 1, Full Control Task Editing	
D2 : Level 2, Full Control Task Editing	
PM : Project Manager/Administrator

Read Only Limited Partial Full Control

A1 B1 B2 C1 C2 D1 D2 PM

Create task

Reopen completed task

Task

Read

Edit Status and % done

Edit Actuals Dates

Add comments

Edit all other fields

Copy task to the same project

Copy / Move task to another project

Delete task

Assignment

Assign users

Documents

Add/Delete documents

Lock/Unlock documents

Unlock documents locked by others

Make own document private/public

Make other’s documents private/public

Dependencies

Create/Delete dependencies

Details
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Project Manager
		  The project manager access right is used to grant full control over the project. As a project manager, a user can perform the following actions:

•	Manage the project’s structure: 
					     ¤ The project’s basic values (e.g. project number, project name, start date, due-date, etc.). 
					     ¤ Assign and un-assign users as well as their project access rights. 
					     ¤ Make changes to task parameters, such as task groups, statuses, types, and priorities.

•	The “Project Manager” access right automatically grants the “Time Approval”, “Project Access” (Can Open this Project) access rights as well as the highest “Edit  
				    Task Level” (D2 - Level 2, Full Control). Furthermore, the Project Manager can edit work items (timesheet entries) and expenses recorded against the project.

Time Approval
		  The time approval access right is used to grant the privilege to approve/reject time sheets submitted by users assigned to the project. Furthermore, this access right enables  
		  a user to generate time reports and, as a result, view the other user’s timesheets in the project. However, only project managers and administrators can edit the other user’s  
		  timesheets.

Expense Approval
		  The Expense approval access right is used to grant the privilege to approve/reject expenses submitted by users assigned to the project. Furthermore, this access right  
		  enables a user to generate expense reports and, as a result, view the other user’s expenses in the project. However, only project managers and administrators can edit the 	
		  other user’s expenses

Project Access (Can open this project)
		  The can open this project access right is used to grant the privilege to view all the project’s data.

•	If the user can open the project, he/she will get access to the project’s tab, that is, all project data (calendars, charts, statistics, discussion forums, reports, among others).

•	If a user cannot open the project, he/she will only see his/her assigned tasks under “My Office -> My Tasks”. In that case, the open project tab is not available.
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CONTACT US
Sales, Customer Service and Technical Support 
For prospective and existing customers - to inquire about our product or to get help on your account.

Email: support@aceproject.com	
Phone (Toll free for US and Canada): 866.259.2454	
International: +1.418.907.5184	
Fax: +1.418.907.8089

We are available between 8:30 A.M. and 4:30 P.M. [Eastern Standard Time], Monday to Friday.

Billing / Accounting 
For everything related to invoicing, declined transactions, credit card, check and wire transfer payments.

Email: finance@aceproject.com	
Phone (Toll free for US and Canada): 888.206.3505	
International: +1.418.907.5227	
Fax: +1.418.907.8089

We are available between 8:00 A.M. and 4:00 P.M. [Eastern Standard Time], Monday to Friday.

Mailing Address

Websystems Inc.	
825, Lebourgneuf Blvd.	
Office #212	
Quebec, QC	
Canada G2J 0B9

http://www.aceproject.com/contact.htm
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