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Welcome to AceProject!
This document is intended for new users of AceProject. It provides an easy step-by-step procedure to create your account, users, projects, tasks, and much more. All you have to 
do is follow these steps to configure AceProject and benefit from its full capabilities. Here are the steps you should follow to get started with AceProject properly.

1.0 - Create your account and your main user
This is the first prerequisite. You can create your free account quickly and easily in seconds. The account you create can be migrated to any paid package later if you wish.  
No matter which package you subscribe to, you must create a free account first.

1.	 Go to http://www.aceproject.com/server01/CreateAccount.asp?lang=EN.

2.	 Enter your the name of your account (for example : Global Institute for Software Technology).

3.	 Choose an account ID (for example : gist). 

4.	 Choose your time zone.

5.	 Choose your preferred date format.

6.	 Define the “week management.”

7.	 Create yourself as an administrator user.

8.	 Enter your name and email address, then choose a username and a password.

 
Make sure you enter a valid email address in order to receive the welcome email and other 
notifications. 

Once your account is created, you will be automatically logged into it. AceProject will create a  
new project for you and assign you to this project. You are now ready to manage projects!

2.0 - Understand the interface
In order to avoid getting lost and waste time searching for specific items, we strongly recommend you read this section. AceProject uses tab navigation. This section explains what 
can be found under each tab.

The elements displayed on the left menu differ from one tab to another. 

3.0 - Set your account preferences
Before you enter any additional data in your account, we recommend you configure it to fit your needs. This section will help you configure items that impact all users and all projects. 

We suggest you review and configure (if necessary) the following, under “Administration -> Configuration”.

3.1 - Account Info
			  This is where you can configure:

	 •	 Your organization’s information.

	 •	 The default time zone.

	 •	 Date format.

	 •	 Week management.

	 •	 Email notification options.

	 •	 The custom SMTP server options.

	 •	 The “Task Reminder” feature.

3.2 - Branding
			  This feature lets you adapt the following visual elements of AceProject to your needs.

	 •	 Apply one of the nine (9) predefined  
		  interface skin themes, or change the  
		  color of specific interface elements  
		  separately.

	 •	 Substitute AceProject’s logo with yours  
		  at the upper left of the application, as  
		  well as on the login page.

	 •	 Change the header background.

	 •	 Rename the application. 
	  
	 * The “Interface Skin” option is available in all packages. The other branding options are available in Hosted Gold and Source Code packages only.

Order of  
Appearance

Tab Name Description

1 My Office
This tab is the connected user’s personal section. This is where each user can view his/her assigned projects and tasks, change his/her preferences, send messages, and 
more. All users have their own “My Office” section.

2 Project tab
This tab displays the open project information. This tab bears the name of the open project. For the selected project, it displays the lists of tasks, reports, Gantt charts, the 
discussion forum, and more. Only users with the proper access rights can access this tab.

3 Portfolio
This tab provides statistics and reports for the user’s assigned projects or all projects in the account, depending on the user’s access rights. Among other features, the “Port-
folio” tab provides Gantt charts, calendars, task reports and time reports.

4 Admin This tab is the account’s control panel. It enables administrators to manage the account itself as well as all users.

5 Help
This tab displays our support system, where you will find answers to your questions about AceProject. This section contains documentation in several formats:  
HTML documents, video tutorials and PDFs.
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3.3 - Configuration
			  The following items are used throughout the account.

	 •	 Clients
		  Clients can be associated with a project they are involved in. You can enter detailed contact information for each client.

	 •	 User Groups
		  User Groups are helpful to organize users in teams or departments, for easier management. You can create user groups to identify “Engineers”, “Webmasters” or 
		  Managers,” for example.

	 •	 Time Types
		  Time Types are work hour classifications, which are used to identify work items when filling out time sheets. For example, time types can be “Regular”, “Sick Time”  
		  or “Overtime.”

	 •	 Project Types
		  Project types are used to categorize projects in your account, for easier management. For example, project types can be “R&D”, “Maintenance” or “General”.

	 •	 Project Priorities
		  Project Priorities help you manage projects. For example, project priorities can be “Low”, “Urgent” or “Critical”.

	 •	 Project Statuses
		  Project Statuses are the state of completion of each project. A pre-defined type must be associated to each status (Waiting, In Progress and Completed). i.e. “To Do”  
		  (“Waiting” type), “Ongoing” (“In Progress” type), “Finished” (“Completed” type).

4.0 - Step 1. Create users
First of all, you must define who will use AceProject in your organization. Here is how you can configure users in your account.

4.1 - What is a user?
			  Each individual who needs to access your projects and tasks must be defined as a user in your account. A user can be an employee, a subcontractor, a customer, or any  
			  other collaborator.

			  Each user can be granted different access rights, depending on how he or she is involved in your ongoing activity. You can also define specific preferences for each user.

4.2 - Create users
	 1.	 Go to “Admin -> All Users” and click the “Add a User” link at the upper right.

	 2.	 Choose a username, a password, and confirm the password.

	 3.	 You can associate the user to a “User Group” by choosing one from the corresponding  
			   drop-down list. This field is optional.

	 4.	 The “Contact” section is used to enter the user’s personal information, such as phone  
			   numbers and email address.

	 5.	 You must define the user’s access rights. You can find all details about access rights here.

	 6.	 You can define additional preferences on the right.

	 7.	 You may send the connection information to the user by checking the corresponding box,  
			   at the lower right of the form.

	 8.	 Click “Save”. You are done! The new user has been added to AceProject.

5.0 - Step 2. Configure your first project
Once you have created all users in your account, you are ready to configure your first project. Here’s how to configure the structure of your first project and assign users to it.

As you may have noticed, a project example named “New Project” and numbered “PROJ-001” has been automatically created in your account. 

Now, two options are available to you: Modify the project example we created for you or start from scratch and create a new project.

5.1 - Modify the project example we created for you
			  To open the project example, go to “Portfolio -> Projects” and click the project number to open the “Edit Project Information” page. This page lets you view the project  
			  structure. In order to adapt this project to your needs, we suggest you configure the following:  
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5.1.1 - Basic parameters

•	 Project Number

•	 Project Name

•	 Start-Date

•	 Due-Date

•	 Contact Information

5.1.2 - Advanced parameters

•	 Task dependency options

•	 Project Type

•	 Project Status

•	 Project Priority

http://www.aceproject.com/support/4.7/html/GettingStartedStep1.asp
https://www.aceproject.com/support/4.7/HTML/Help-AccessRights.asp
http://www.aceproject.com/support/4.7/html/GettingStartedStep2.asp


5.2 - Start from scratch and create a new project
			  To create a new project, go to “Admin -> Projects” and click the “Add a Project” link at the upper right. From there, 2 options are available to you:  
 
					    5.2.1 - Create a blank project
					    Use this option if you wish to create a brand new project. Additionally, you can check the  
					    “Create default values...” box to auto-populate default task groups, task types, task  
					    statuses and task priorities. Otherwise, these elements must be configured manually.

					    Here’s how to configure a blank project:

•	 Fill out the “New Project” page. The following fields are mandatory: Project  
				    Number, Project Name, Project Type and Project Priority.

•	 Define your own task groups, task types, task statuses and task priorities.

•	 Assign users to the project by clicking “Save + Assign Users” at the bottom left.  
				    Each user can be granted access rights specific to his or her functions. 

 
					    5.2.2 - Copy a project from a template
					    Use this option if you wish to borrow an existing project’s structure to create a new project. Using this option can make you save time, since this ensures that the exact  
					    same structure will be used from one project to the other. You can check which of the template’s items you wish to copy.

					    The following options are available when you copy a project template:

•	 Choose the template you wish to use from the drop-down list.

•	 Check  the items to copy from that template (assignments, documents, etc.).

•	 Once you choose the new project’s start date, AceProject can adjust the task  
				    dates from the template.

•	 You may also reset all task statuses to a “Waiting” status.

					    You can make a template from any project easily by checking the “Project Template” box. 
				         In 	order to copy a template, you must be assigned as a “Project Manager” on it.

					    You can link the child project you are creating with its parent by checking the corresponding box. Linking a child project to its parent ensures that the child project’s structure  
					    (task groups, task types, task statuses and task priorities) will always be identical to its parent’s. Note that this option is available when a project template is copied only.  

5.3 - Assign users to the project
	 1.	 From the “Edit Project Information” page, select the “Assignment” tab and click the  

			   “Assign a New User” link at the upper right.

	 2.	 Choose users from the list box, which lists all existing users in your account.

	 3.	 You must provide the users with access rights at the project level (the access rights you  
			   granted on the previous step are at the account level).

	 4.	 Click “Save” when you are done. 

5.4 - Configure the project structure
			  This is where you define categories and tags for your tasks. The last four tabs in the “Edit Project Information” page let you configure “Task Groups”, “Task Types”, “Task  
			  Statuses” and “Task Priorities”. You can add an item in either of these categories by clicking the corresponding tab and by clicking the “Add a ...” link at the upper right of the  
			  corresponding page. Do not forget to click “Save” when you are done. 
 
					    5.4.1 - Task Groups
					    They are used to separate your project in phases or modules. You can also use Task Groups to simulate sub-projects. 
					    i.e. “Phase A”, “Phase B”, “Phase C”.

					      
					    5.4.2 - Task Types
					    They are used to separate your tasks by work category. 
					    i.e. “Programming”, “Meetings”, “Bugs & Issues”.

					      
					    5.4.3 - Task Statuses
					    They are used to inform on the state of completion of each task. A pre-defined “Type” must be associated to each status (Waiting, In Progress and Completed). 
					    i.e. “To Do” (“Waiting” type), “Ongoing” (“In Progress” type), “Finished” (“Completed” type).

					      
					    5.4.4 - Task Priorities
					    They are used to prioritize your tasks and to define the level or urgency of each task. 
					    i.e. “Low”, “Urgent”, “Critical”.
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6.0 - Step 3. Add tasks to your first project
Now that your project structure is configured, you can start adding tasks to that project. This step shows how to create tasks, assign users and attach task documents.

6.1 - Enter the main task information
			  Whenever a task is created in AceProject, it must be associated with a specific project. A user must be assigned to the project in order to be assigned to tasks within that project. 

1.	 Go to “My Office -> My Projects -> My Assigned Projects” and  
			   open your project by clicking its name.

2.	 Click the “Add a Task” link, at the upper right of the “Incomplete  
			   Tasks” page.

3.	 Enter the main task information under the “New Task” tab. When  
			   you are done, click the “Save” button to save the task and leave  
			   it non-assigned or click the arrow next to the “Save” button to save  
			   the task and perform further actions.

6.2 - Assign users
1.	 Once you have entered the task information, click the  

			   “Assignment” tab, in the “Edit Task Information” page.

2.	 All users who are assigned to the project are displayed there.  
			   Simply check the ones you wish to assign to the task. Click  
			   “Update” when you are done, or click the arrow next to the  
			   “Update” button to save your changes and perform further actions.

6.3 - Attach documents
			  Task documents are useful if you need to provide assigned users with extra information. For example, you might need to attach pictures or PDF files that are necessary to  
			  complete the task.

			  Here’s the procedure to attach a document to a task:

1.	 Locate the document in your computer by clicking the “Browse...” button.

2.	 Enter a description to inform other users about the document’s content.

3.	 Enter a version number (useful if you need to keep a history of different  
			   iterations made to the same document).

4.	 You can lock the document to prevent other users from overwriting it. 	  
			   If it is unlocked, other users can overwrite the document if they down 
			   load it, modify it, and upload it with the same version number. If the  
			   document is locked, other users can download it, but they cannot  
			   upload and overwrite the document.

5.	 The document can be made “Public”. When public, a document can be  
			   downloaded by anyone (even non-users) via its download link, without  
			   a login and a password to AceProject. When private, a document can  
			   be accessed by AceProject users only.

6.	 Click “Upload” document when you are done or click the arrow next to the  
			   “Upload Document” button to upload the documents and perform further  
			   actions.

7.0 - Step 4. Modify your user preferences
In order to optimize your experience with AceProject, you can edit various settings such as the number of projects/tasks displayed on each page, a specific project to open upon 
login, and more. This step walks you through this.

Before you start using AceProject, we suggest you review your user preferences. Here are some of the most important preferences you should review under “My Office -> My 
Preferences”:

1.	 Change your password and your contact  
		  information at any time.

2.	 Decide whether you wish to receive email  
		  notifications or not.

3.	 Define how many tasks and projects to display  
		  per page in task and project reports.

4.	 Select a project to open upon login.

5.	 Choose your preferred date format and time zone.

8.0 - Other Features
Now that you are all set, we suggest you take a look at these key features that will help enhance your productivity. 

Here are AceProject’s main features.

8.1 - Time Tracking
			  There are two ways users can fill time sheets:

1.	 Manually through the time sheet module.

2.	 Automatically through the IN/OUT time clock module.
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					    8.1.1 - Time Sheet Module
					    With this module, users fill out their time sheets manually by selecting a project, a task, a time type and typing the number of hours worked. Here’s the procedure to fill  
					    a time sheet: 

1.	 Go to “My Office -> My Time Sheets -> My Weekly Time Sheets”.

2.	 Click an existing week to open it, or create a new one by clicking the “Add a New Week” link, at the upper right.

3.	 Select the project you are working on from the “Quick Action”.

4.	 Select the task you are working on from the corresponding drop-down list, select your time type and enter the number of hours you worked on that task. You can also  
		  enter comments related to the work you have done.

5.	 Click “Save” when you are done.

					    8.1.2 - Time Approval
					    Once your time sheet is filled, it can be sent to a project manager for approval. Here’s how you do this:

1.	 Select an approver from in the corresponding drop-down list at the lower left.

2.	 Type a message if you wish.

3.	 Click the “Send Approval Request” button to send your time sheet for approval.

 
					    * The users who are allowed to approve time sheets are the following: Administrators, and normal users who are granted the “Project Manager” or the “Time Approval”  
					    access rights in projects that are included in the week you are actually sending for approval.

					    8.1.3 - IN/OUT Time Clock Module
					    This module records the time you spend on a task automatically. All you need to do is start the time clock when you start working on a task, and close it when you are  
					    finished. Here’s the procedure to use the IN/OUT time clock module:

1.	 Go to “My Office -> My Time Sheets -> My In/Out”,  
		  (alternative procedure: open a task from any task list by  
		  clicking its summary and click the “Open IN/OUT” link at the  
		  upper right of the “Edit Task Information” page. 

2.	 Select the project and the task you are working on, a time  
		  type, and enter comments if necessary. Click the “Open  
		  (IN)” button to start the time clock.

3.	 When you are done, go back to “My Office -> My Time  
		  Sheets -> My In/Out” to stop the time clock (alternative  
		  procedure: go to “My Office -> My Tasks” and click the clock  
		  icon next to the corresponding task summary).

4.	 Apply any necessary modification and click the “Close  
		  (OUT)” button when you are done.

 
					    * Depending on your access rights, you may or may not be able to modify your time manually.  

					    8.1.4 - Time Reports
					    These reports display all work items you entered using the “Time Sheet” and the “IN/OUT Time Clock” modules. Depending on your access rights, you may have access to time  
					    reports under the “Project” tab, under the “Admin” tab, and under the “Portfolio” tab. All users can generate their personal time report in the “My Office” section. 

					    Here’s how you can generate a personal time report:

1.	 Go to: 
		  “My Office -> My Time Sheets -> My Time Report”.

2.	 Select the filters you need and enter a date range, if  
		  necessary. 

3.	 Click the “Generate” button to view your report in  
		  AceProject, or click “Export” to view your report in  
		  Excel or in CSV format.
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8.2 - Discussion Forum
			  One discussion forum is available for each project. All users with the “Can Open  
			  this Project” access right can access this feature under the “Project” tab. It is  
			  quite useful to post issues, provide help to other assigned users, share ideas  
			  or simply to communicate with other users about the ongoing project.

8.3 - My Mailbox
			  This messaging feature lets you send emails to other existing users in your  
			  account. You can use this tool to communicate quickly with all assigned users on  
			  a specific project, with all administrators or with selected users. You can even  
			  receive an email notification in an external inbox when you have received a new  
			  message in your mailbox.  
		   
			  This 	feature is available under “My Office -> My Mailbox”.

8.4 - Excel / CSV Data Export
			  Users, projects, tasks and time sheets can be exported in Excel or in CSV format. Most reports are  
			  exportable as well. This feature is useful to archive data or to work offline.  
			  You can also use this feature to batch update tasks or users, and import them back afterwards. This can  
			  make you save lots of time since you can update lots of data faster 	than if you had to go through the  
			  web interface.

			  To export data, click the “Export” link whenever you see it, or go under “Admin -> Administrative Tools ->  
			  Export Data”.

8.5 - CSV Data Import
			  Users and tasks can be imported in AceProject in CSV format. You can import previously-exported data  
			  you may have edited offline in Excel. You can also use this feature update several tasks or users at once,  
			  and import them back into AceProject afterwards. The CSV Data Import is a real time saver: you can  
			  update lots of data faster than if you had to go through the web interface.

			  To import data, you must go under “Administration -> Administrative Tools -> Import Data”.

8.6 - Task Reports
			  Reports are among AceProject’s specialties. Task reports contain filters you can apply to refine the information you want to see.

8.7 - Calendars
			  Calendars display the list of tasks that start and end during a given week or month.

8.8 - Gantt Charts
			  Gantt charts show the progress of each task or each project, in a graph.
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CONTACT US
Sales, Customer Service and Technical Support 
For prospective and existing customers - to inquire about our product or to get help on your account.

Email: support@aceproject.com 
Phone (Toll free for US and Canada): 866.259.2454 
International: +1.418.907.5184 
Fax: +1.418.907.8089

We are available between 8:30 A.M. and 4:30 P.M. [Eastern Standard Time], Monday to Friday.

Billing / Accounting 
For everything related to invoicing, declined transactions, credit card, check and wire transfer payments.

Email: finance@aceproject.com 
Phone (Toll free for US and Canada): 888.206.3505 
International: +1.418.907.5227 
Fax: +1.418.907.8089

We are available between 8:00 A.M. and 4:00 P.M. [Eastern Standard Time], Monday to Friday.

Mailing Address

Websystems Inc. 
825, Lebourgneuf Blvd. 
Office #212 
Quebec, QC 
Canada G2J 0B9
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